Jump to content
Martijn Meerts

Reporting bugs and feature requests

Recommended Posts

Sascha

I uploaded a second album, and it went ok.

Share this post


Link to post
Martijn Meerts

First of all, sorry for my absence. Like Jeff mentioned, I've been really busy with work lately. I've taken over an old code base from another developer, and I'm currently the main developer of that codebase. Wouldn't be much of a problem if not for the fact that the codebase is the internal CRM/ERP system which is used to take care of all stock, orders, invoices, deliveries and lots more. A minor error on my part could easily cost the company hundreds of thousands of euros, so there's quite a lot of stress as well.

 

There have also been some personal issues lately which took my attention away from the forum and model trains in general. I haven't done any work on my layout for many months now, and I'm really not sure when I'll get started on it again.

 

Anyway, I've looked at the database issue. I did notice the database was a little bit slow, but I could connect to it just fine. After the initial connection it was really fast again as well. I did update some software packages on the server as well. As for the forum software update, I haven't had much time to look at that either, but I'll try to look into that in the coming days. There are a lot of people on holiday at work now, so it's a little bit less busy, so I might actually not be totally exhausted after coming home after work...

  • Like 6
  • Thanks 1

Share this post


Link to post
railsquid

The database errors seem to have stopped some time in the last 24 hours.

Share this post


Link to post
cteno4

good work martijn, they have stopped here!

 

jeff

Share this post


Link to post
JR 500系

Yes thank you Martijn for the hard work! much appreciated!

Share this post


Link to post
Sascha

Also thanks from me!!!

Share this post


Link to post
Yavianice

Since the new software update, I can't login through Tapatalk anymore, and now it does no longer open JNS forum. Is Tapatalk disabled for use, or will it be fixed in the future?

Tapatalk gives error 2205.

Also I experience the desktop version of the website to be very, very slow now.

Share this post


Link to post
kvp
40 minutes ago, Yavianice said:

Also I experience the desktop version of the website to be very, very slow now.

Yes, especially with activity filters.

I had to set up the following filter to get something similar to the old new content view:

Quote

 

Show me: Items only; Any tags
Content Types: Topics
Read Status: Everything
Ownership: Everything
Following: Everything
Time Period: Past 7 days
Sorting: Newest first

Condensed

 

And the style still takes up too much screen space. On the other hand, the mobile view has the page title on 25% of the screen and tends to glitch the chrome brower on my phone (tried two different versions on two different android phones), so it's either a layout or a script bug somewhere.

Share this post


Link to post
Martijn Meerts

I'll have a look at the tapatalk thing. With the previous version I had to install an add-on, so it's likely I have to do the same with the current version.

As for the slowness, I'm experiencing the same thing. I'm at the office at the moment, so can't really look into it right now, but I'll try to figure out what's going on tonight. The background processes are all done, so that shouldn't be causing any slowdowns anymore at least.

  • Thanks 1

Share this post


Link to post
IST

The forum is slow here also, but hey Martin, thanks for your efforts to keep our forum updated!

Share this post


Link to post
Martijn Meerts

I think the forum being slow is something with the server. When I get home tonight I'll see if it needs any updates, and then give it a reboot. I'm also going to research if I can update the PHP version used without the forum breaking. During the forum software update, it did say PHP7 was recommended, so I'm assuming upgrading to PHP7 should work just fine. PHP7 has better performance and uses less RAM than our current PHP version, so that's definitely something to look at.

I'm also going to look into a couple of other things such as caching (apparently, some caching engines don't work well with the forum software unless you give it a LOT of RAM to work with), and maybe see if I can find some settings in the database to optimise throughput there a little bit.

Unfortunately, I don't have the SSH key on my work computer, so it'll have to wait until I get home, but I'll check it out as soon as I can.

Share this post


Link to post
Martijn Meerts

Tapatalk should be useable again now, I installed their plugin and fixed some things on the Tapatalk admin panel.

 

Speed is normal again as well for now, hopefully it won't slow down to a crawl when I'm at the office again.

 

As for the style/layout issues. If you come across any, it would be great if you could take a screenshot of the issue, that would make it much easier for us to figure out the exact issue. 

  • Like 2
  • Thanks 2

Share this post


Link to post
Yavianice

I can confirm that Tapatalk works again! Thanks Martijn!


Sent from my iPad using Tapatalk

Share this post


Link to post
Sascha

Thanks for all your work Martjin. I really like the new look.

Share this post


Link to post
kvp

Not a bug, but imho the header looks a bit huge on mobile screens.

Screenshot_2017-08-23-10-04-16.png

Share this post


Link to post
Martijn Meerts

Noticed that as well, I guess the easy fix is to change it to JNS Forum :)

  • Like 1

Share this post


Link to post
miyakoji

But overall the new look of the mobile and desktop sites are an improvement, thanks for the work Martijn.

Share this post


Link to post
JR 500系

Many thanks for the hard work Martijn! The new look is pretty interesting!

Share this post


Link to post
serotta1972

Thank you for all your hard work Martjin!  But hey I thought there would be some orange in the new format. :)

Share this post


Link to post
Martijn Meerts

We're currently just using the default theme that comes with this version of the software. Once everything is stable and any remaining issues are ironed out, we'll start working on some custom themes. The first one will likely be based on the colours of the old forum, so the Hikari Rail Star colours)

  • Like 4
  • Thanks 1

Share this post


Link to post
katoftw

If i use the read new content feature. It takes me to the first post on the first page of the thread. Not to the actual unread content itself.

Share this post


Link to post
Densha

If you use the correct filters it will take you to the first post. Click on the 'Read Status' tab and then select  'Unread item links take me to the first comment'.

You can filter for certain content using the other tabs as well. If you are satisfied with a certain setting, just hit the 'Save As New Stream' button and hit the check mark next to the stream title to make it your default setting when you look for Unread Content.

Share this post


Link to post
cteno4

Under the general unread content list you can jump to the most recent post by clicking on the time (i.e. 1hr ago) in the lower left of each listed post.

or as densha says you can see up your own stream that has the post titles going to the most recent post, but that will not function directly from the unread content link at the top right of all pages.

jeff

Share this post


Link to post
katoftw

Wont save filters. And there is nothing to select in bottom left corner.

 

The filters work. But go back a second time and it is all lost.

Share this post


Link to post
cteno4

Kato,

in the box for each post on the unread content list there is a time link (like 6 minutes ago or 2 hours ago) that takes you to the latest post in that thread. In the condensed view it's on the right side of each post box and in the extended view it's in the lower left corner of each box.

When you save a custom stream it show up in the bottom section of the my active streams pulldown menu in the activity section.

jeff

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×