Jump to content
Japanese Modelling & Japan Rail Enthusiasts Forum
Martijn Meerts

Reporting bugs and feature requests

Recommended Posts

If you find a bug, or have a feature request or something similar, please start a new topic about it in this forum. That way it's easy for us to keep track of everything ;)

 

If you just want to make some test post (for example, to try attaching images to a post, or, once online, try attaching gallery images), please reply to the 'Test posts only' topic.

 

Thanks! :)

 

Share this post


Link to post
Share on other sites
cteno4   

martijn,

 

sorry to have a report, but the page jump seems to have broken this morning on the individual thread post. it was working last night. 

 

what ever i put in it just jumps back to the first page (ie oldest post)

 

jeff

Share this post


Link to post
Share on other sites

If you use the 'view new content' link in the menu bar, and then click on the little orange icon on the left (usually a dot or a star), you should go straight to the last unread post. It's not very obvious, so I'll look into changing it, maybe just add a textual 'to first unread post' under the topic title.

Share this post


Link to post
Share on other sites

Do we have the ability to see the newest post first? Not just the first unread post, but to flip the whole thread so you see the last post first.  It really helps with threads like ''What do you order or the post deliver''.

Share this post


Link to post
Share on other sites
Do we have the ability to see the newest post first? Not just the first unread post, but to flip the whole thread so you see the last post first.  It really helps with threads like ''What do you order or the post deliver''.

 

You're not the first one to ask for that :)

 

Unfortunately, at the moment it's a global setting, so we can only flip it for everyone or no one. I'm looking into it though, hopefully I'll be able to write some custom code that adds a setting to the user control panel.

 

While testing it never really occurred to me that people read forums the 'other way around', which is really why I hadn't looked at it earlier.

  • Like 1

Share this post


Link to post
Share on other sites

Ah, or you can click on the date and time of the latest post to go right to it. Not immediately clear, but it works fine as-is, I think.

Share this post


Link to post
Share on other sites

1) I liked the list of websites (like quinntopia, etc) on the right side of the screen in the old forum.  Is that somewhere and I'm missing it?  

 

2) When I click on the JNS logo at the top, I end up at the community/forum page, and not the main page.  Probably doesn't matter too much, but I wasn't sure how to navigate to the main page (because I was trying to find the list of forums mentioned in item #1)

 

3) when I click on "new content", "content I have not read", I get an empty list

 

4) it's been beat to death and answered, but everything is very. slow.

 

but it looks great!

 

Share this post


Link to post
Share on other sites

1. That's not implemented (yet). We're thinking of making it a special page, which gives us room to list multiple rss feeds.

 

2. The logo links to the forums themselves, which is the more important bit. I can change it to link to the home page, or I can add a 'home' button in the menu bar which links to the homepage.

 

3. Not sure what the cause of that could be. I haven't had any issues myself, but one of the first things I did was click the 'mark community read' link in the bottom. After that it's been working fine.

 

4. Again, I'm not sure what's really causing that. I have some ideas that might help, but again, I'm not really finding the forum very slow on my end. Not quite as quick as the previous, but not overly slow either...

Share this post


Link to post
Share on other sites
cteno4   

on 3 ive been trying to figure out how this works. many times its empty for me when there are several new posts (to threads ive looked at before or posted to) in the past 24 hrs or since my last visit. 

 

right now its working properly with the same unread new threads listed in all three, but it was variable the last couple of days.

 

well i just whittled the not read down from 4 to 1 and then all of a sudden the content i have not read yet went to empty but still showed the correct one left in new since last visit or past 24 hrs. its quirky all right.

 

jeff

Edited by cteno4

Share this post


Link to post
Share on other sites

Might be things just need to settle a bit after the conversion. I haven't made any changes to the underlying system, only to the templates, so if the unread content doesn't work properly it's either a bug in the software (which I doubt), or a remnant of the conversion, which should hopefully fix itself.

Share this post


Link to post
Share on other sites
cteno4   

in the last couple of days i have not noticed it, but used the since last visit mostly, but ill keep checking. i agree its hopefully just something in the db digesting the whole forum conversion and perhaps will just go away on its own. anyhow using since last visit seems to solve the problem. not a biggie at all, just trying to get you more info on the bugs that are in the air, i know how frustrating it can be when you hear of a bug but have so little data on how it pops up and the random ones are the worst!

 

thanks again for all the hard work on this martijn, things are running well, dont exhaust yourself over all this!

 

cheers

 

jeff

Share this post


Link to post
Share on other sites

Being a developer working with clients every now and then, I get bug reports that basically just say "the site doesn't work", without further information at all. When you ask for more details you usually end up waiting about a week for a reply, and when you get one it says "the site still doesn't work" =)

Share this post


Link to post
Share on other sites
IST   

Is the post counter working?

Currently I have no info in the 'Today top posters' section and my post counter does not work also. Not a huge issue, I can leave without it, I am just curious.

Share this post


Link to post
Share on other sites
miyakoji   
Is the post counter working?

Currently I have no info in the 'Today top posters' section and my post counter does not work also. Not a huge issue, I can leave without it, I am just curious.

I think I noticed something related to this. I was looking at recently registered users, and at least one who definitely has posts, KVH1, is listed as having zero.

Share this post


Link to post
Share on other sites
Tecchan   

I don't know if this has been discussed before but I really miss the "mark as all read" button.

I wasn't able to find it. :-(

Share this post


Link to post
Share on other sites

Sorry for the late reply, been really busy lately with a variety of things ..

 

 

The post counter seems a bit random at times. I've noticed that not all posts are being counted, and sometimes the counter is only updated a few days after a post was made. It might be some setting in the back end somewhere, or it might have something to do with the changes I made to the visibility of the post count on the forum.

 

There are still several things that need to be fixed/added, I just haven't really had the time to sit down and get them done. Work, traveling to and from work, preparing dinner for myself and the parrot, and often working extra hours from home leaves me very little spare time. Once I do get some spare time I tend to be asleep during most of that ;)

 

 

 

I don't know if this has been discussed before but I really miss the "mark as all read" button.

I wasn't able to find it. :-(

 

As mentioned in another post, it's all the way in the bottom as 'mark community read', and yes, it's in a weird position ;)

Share this post


Link to post
Share on other sites
cteno4   

sleep, sleep, martijn you dont need no stinkin sleep!

 

the board has been running well and is getting the job done well. most of the stuff now is just little irks or would be nice things, so get a nap and feed the parrot (he will let you know if you dont!) Are you talking to the parrot now?

 

cheers

 

jeff

Share this post


Link to post
Share on other sites

On average I'm sleeping about 5 hours a day, including the weekends, and I STILL don't have enough time to do the stuff I want to do :)

 

I talk to the parrot all the time, he's just not talking back yet, although it does sound like he's practicing during the late evenings just before he goes to sleep. Sometimes he gets a bit worked up, almost like he's angry because he's not getting the words out, and starts screaming like a madmen. Normally only lasts a couple of seconds thankfully.

Share this post


Link to post
Share on other sites
cteno4   

martijn,

 

you sound like a younger me. too many years of little sleep at times it felt like life was 2x. 

 

Ha just hope you dont have the terrible twos to go through with him! probably better than talking to yourself.

 

jeff

Share this post


Link to post
Share on other sites

The search function can't find 3-letter strings. For example, there are no results for "C56".  :(

Share this post


Link to post
Share on other sites
Densha   

Anything under four characters doesn't work. I don't like the search function anyway, I often can't find things back with it even when I use the "only search in titles" option, and the way it is and somehow (while not always) the order seemed a bit weird to me.

Share this post


Link to post
Share on other sites
cteno4   

the search function is annoying, i rarely find it finds stuff for me when i know what i was looking for. i worry newbies will just get the shotgun blast it seems to bring back. this just pushes the forum much more into the "now" unfortunately.

 

searching titles only helps and putting good titles on posts as well.

 

do tags under 4 characters work?

 

jeff

Share this post


Link to post
Share on other sites
miyakoji   

Jeff, I think tags are the answer to the problem.  It looks like tags that are 2 characters or longer work correctly: http://www.jnsforum.com/community/topic/7720-test-post-for-short-tags/

 

Based on my observation, though, no one is using tags other than me and Bikkuri, and I was trying to keep a list of tags in use but this thread got some spam in that's never been deleted (although the spammer was banned), so I don't think anyone is really looking at it: http://www.jnsforum.com/community/topic/7030-using-tags/

Edited by miyakoji

Share this post


Link to post
Share on other sites
KenS   

I'll admit I don't think of putting tags on posts when I start a new thread.  Perhaps the software should suggest some from currently in-use tags based on content of the post and allow you to overrule it. That would serve a reminder that something ought to be used.

 

I'd be surprised if someone, somewhere, hadn't already written that function for some forum software, so maybe something could be found and adapted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×