Jump to content

The Train Doctor

Help! My train is broken!

303 topics in this forum

  1. Lubricants

    • 58 replies
    • 14,623 views
    • 27 replies
    • 426 views
  2. DE10 = DEAD

    • 92 replies
    • 10,532 views
  3. Atlas MP15 HELP!!

    • 117 replies
    • 9,519 views
  4. Kato Point derail - advice ?

    • 30 replies
    • 6,853 views
  5. Traction Tyres - friend or foe ?

    • 124 replies
    • 5,476 views
  6. Tomix 209-0 fits and starts, and growling

    • 44 replies
    • 4,685 views
  7. Weird sound coming from motor Tomix Kiha 40

    • 72 replies
    • 4,531 views
  8. Having some problems on my track.

    • 30 replies
    • 3,896 views
  9. Tomix 115 Running Jerkily

    • 33 replies
    • 3,886 views
  10. Saggy Bottom Trolley

    • 16 replies
    • 3,686 views
  11. superglue mistakes

    • 3 replies
    • 3,555 views
  12. The Perplexing Case Of The Melty Lounge Cars

    • 62 replies
    • 3,329 views
  13. Repair points on Kato #4 Turnout?

    • 5 replies
    • 3,039 views
  14. Grumbling

    • 25 replies
    • 3,038 views
  15. Kato EF65 Conundrum

    • 43 replies
    • 3,038 views
    • 25 replies
    • 2,979 views
  16. Portram which isn't run

    • 18 replies
    • 2,978 views
  17. KATO N700 Series Shinkansen Bullet Train "Nozomi"

    • 35 replies
    • 2,903 views
    • 21 replies
    • 2,869 views
  18. MicroAce KiHa 91 - Coupler problems

    • 26 replies
    • 2,622 views
  19. Noisy E531 - Kato

    • 17 replies
    • 2,601 views
    • 21 replies
    • 2,527 views
    • 5 replies
    • 2,520 views
  20. Kato spares, help needed

    • 9 replies
    • 2,417 views
×