Jump to content

The Train Doctor

Help! My train is broken!

303 topics in this forum

  1. Lubricants

    • 58 replies
    • 14,627 views
    • 27 replies
    • 431 views
  2. Traction Tyres - friend or foe ?

    • 124 replies
    • 5,485 views
  3. Atlas MP15 HELP!!

    • 117 replies
    • 9,521 views
  4. DE10 = DEAD

    • 92 replies
    • 10,538 views
  5. Weird sound coming from motor Tomix Kiha 40

    • 72 replies
    • 4,531 views
  6. The Perplexing Case Of The Melty Lounge Cars

    • 62 replies
    • 3,329 views
  7. Tomix 209-0 fits and starts, and growling

    • 44 replies
    • 4,685 views
  8. Kato EF65 Conundrum

    • 43 replies
    • 3,038 views
  9. C56 with backwards axle bearing

    • 43 replies
    • 908 views
    • 40 replies
    • 2,234 views
  10. Locate Kato parts?

    • 36 replies
    • 709 views
  11. KATO N700 Series Shinkansen Bullet Train "Nozomi"

    • 35 replies
    • 2,903 views
  12. Tomix 115 Running Jerkily

    • 33 replies
    • 3,887 views
  13. Kato 10-1247 noisy run at speed

    • 32 replies
    • 2,095 views
  14. Kato D51 2016-3 Drawbar repair?

    • 32 replies
    • 972 views
  15. Having some problems on my track.

    • 30 replies
    • 3,896 views
  16. Kato Point derail - advice ?

    • 30 replies
    • 6,853 views
  17. Life Lessons From The Clumsy People

    • 30 replies
    • 2,048 views
  18. Cracked Tomix 300 Series Chassis

    • 29 replies
    • 1,544 views
    • 28 replies
    • 1,653 views
  19. Super noisy E127

    • 28 replies
    • 388 views
    • 27 replies
    • 1,582 views
  20. Two week old Tomix E2 Yamabiko dead

    • 27 replies
    • 717 views
  21. MicroAce KiHa 91 - Coupler problems

    • 26 replies
    • 2,622 views
×