Jump to content

Recent Topics

Kato V1 vs V2 passenger car lighting

DCC, Electrical & Automation Today, 09:10 AM
Folks 11110, vs 11112 I just installed my first set of version 2 LEDs in a passenger set. At least, over the first few days it seems the flickering is MUCH better. I contacted KatoUSA and I can't get just the new boards to update all my other installs. 1) is the a source for the better boards 2)...
Full topic ›

Yubari Railway Wafu

JRail: News, Announcements & General Discussions Today, 02:20 AM
I have ordered a World Craft Yubari #14 to go with my Yubari Railway #11 kit. I am interested in building a Yubari Wafu. Can anyone point me to a drawing or provide the dimensions of the Wafu like the one in the picture? http://ttr.b.la9.jp/.../oyubariwf4.htm http://ttr.b.la9.jp/.../yubariwf4r.j...
Full topic ›

For Sale - Kato and Tomix Trains

Classifieds - For Sale or Trade Yesterday, 08:14 PM
All trains are like new and have less than 10 minutes of run time except for the D51 and old motor chassis on the series 2100.   Prices are firm and does not include shipping.  Willing to ship worldwide.  Payment through PayPal.   Kato 10-1179 Series 287 Kuroshio 6 car set $10...
Full topic ›

Looking for replacement chassis tor Old Kato Motor Cars

The Train Doktor Yesterday, 06:29 PM
Folks I have  a few sets 10-195, 10-807, with the Kato 4048, (motor built into the floor) chassis  drives. On the oldest(10-195) , I think either the motor is failing, or i'm having contact issues. Is there a standard chassis I can buy, ala 11-103 - 107, except that it fits these units?...
Full topic ›

Stuttgart Hbf - full size in N scale

Worldwide Models Yesterday, 12:27 PM
I think I had seen some photos of this previously, but just discovered that it will be going on public exhibition for the first time later this year.  It reflects one man's extreme ambition and accomplishment.   I was stationed in Stuttgart in the mid-60's, and still have strong memorie...
Full topic ›
- - - - -

Forum Validation Troubles


We are having issues with our SMTP server to send out the forum validation emails. Please be patient and we hopefully should have the problem resolved in a few days.

If you know anyone on the forum have them PM cteno4 and we can manually validate their new account.

Sorry for the inconvenience.

Thanks

Jeff


0 Comments